Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

BitComet Yellow Circle Trouble


Recommended Posts

Hello BitComet,

I have had a very frustrating time trying to fix my yellow circle problem, trying to make it green and have read numerous threads and posts attempting many different things and have not come to a method that has fixed my crippled downloads problem. Following the "READ THIS before posting" thread mentions, the following are my details and explanations of how I went about attempting to fix this. Hopefully I can receive some guidance to solve this issue :)

BitComet 1.16

OS: Windows XP Professional Service Pack 3

Router: D-Link DI-524

Modem: D-Link DSL-502T (ADSL2+ Router/modem)

Internet Connection: TPG ADSL2 - Download: 12Mb/s Upload: 0.79Mb/s (Using the speed tester provided on admin's thread)

Computers: 2 laptops, 2 Computers (All on the same networks sharing the same internet from the mentioned Modem and Router)

I have forwarded my Port (50505 is my Listen Port I've Chosen)

Things I have noticed in the BitComet client is that next to the Yellow circle it reads

"Blocked:<My Ip given by my ISP> 50505" It then mentions that Forwarding ports and changing firewall settings will fix this. I have changed settings in my firewall (I use Trend Micro PC-Cillin Internet Secutiry 2007) No changes I have made have given me a green circle.

So basicly, I have no idea what I could Possibly be doing wrong, I've done a lot of reading on this problem and tried most things that are targeted at my systems specifications and not gotten any progress. If someone could give me some help It would be greatly appreciated. Please let me know if further information is needed for you to provide me with help.

List of SOME Guides I have looked at and attempted.





Thank you in advanced,



Link to comment
Share on other sites


Do you use Bitcomet on all 4 computers?

If all 4 computers are connected to the wireless router and you use BitComet on all of them you will need to open the ports on both routers for each computer, up to a total of 8 rules (16 rules if you can't set a rule to allow both udp and tcp). I guess you use the di-524 as a wireless router for your laptops, but you should connect the desktops directly to the modem thus having to forward the ports for the desktops only in the modem.

You'll find detailed guides on how to forward ports at portforward.com, just look for your devices in the router list.

Link to comment
Share on other sites

Vasy, if I'm right, his modem/router has only one Ethernet port, that's why he needs a second device.

Of course a switch would have been a less painful choice. :P

@ Shane284: How are your 4 computers connected to the router (wired, wireless)?

I have forwarded my Port

On which of the 2 routers?

If any of your computers is connected wireless, the simplest solution you could try is to plug the patch-cord coming from your modem in one of the LAN ports of your router, that way bypassing the router function of the device, and using it as a simple switch.

Then forward your port only on the modem/router device (if it isn't already).

Link to comment
Share on other sites

The 502 is a modem/router with only one physical Ethernet port. It uses firmware to distinguish between virtual connections, e.g., on a hub.

The 524 is wireless, with four wired Ethernet ports.

In this setup, the 524 would completely replace the 502's virtual connection firmware.

You'd want to configure the 502 to act as much like an ordinary modem as possible. <-- make that your guiding principle. When in doubt, disable. You'd want most of the 502' features and abilities, especially regarding networking, turned off.

You'd want the 502 acting only in bridge mode with its firewall completely disabled -- use the 524's firewall instead.


There ARE several different ways that this COULD be hooked together, but the fastest way to get deep in trouble, is to listen to several different people all of whom have different ideas about how to do it or assumptions about how you are already doing it. You're also not very good at describing your setup, and I doubt it's even very clear in your mind. So I'm going to bow out of this. There are already too many cooks in the room.

Link to comment
Share on other sites

I got a question....What if you don't have a router? What if you use a direct cable modem and still have the yellow light? Although for the longest time it was at green, up until I installed CA Security (trying it out) Then I noticed the yellow light. I quickly uninstalled CA and cut any loose ends to it. Yet, the yellow light persists, at times the download speeds are fairly well as if the yellow light was in fact green, but sometimes it doesnt even when there is plenty of seeds. My point is, I feel that I'm not getting the full potential because of the yellow light, and having rank as a Major aswell as having the most expensive internet connection, I can only wonder.

Link to comment
Share on other sites

It's a really bad idea, not to mention pretty rude, to jump into the middle of someone else's topic like this. Your issues aren't his issues, so which one of you are we speaking to now? Start your own topic.

Link to comment
Share on other sites

Why? It is clearly the same issue, tis' is not about being rude, saving time and effort on creating another useless topic about the same thing will save you some time aswell. It is wise to think before you say. Besides, the issue has been resolved no? If not, why no responses? I only asked a simple question, I have observed and investigated several forums and topics, I do not see this as a problem.


Link to comment
Share on other sites

You think it's the same issue? Do you have a 504? A 524? Are you trying to couple them? I thought you said you didn't have a router at all, let alone two of them. How, then, is it the same issue? At best it's a vaguely related subject.

Closed? I sure didn't see where anything was resolved. If the guy comes back for more resolution, now he finds you (and your HUGE signature graphic) slap in the middle of things, diverting the discussion to something else entirely. In the event you didn't read the topic, we're trying to avoid re-complicating a very complicated setup by having too many of us jump into it.

As for whether it's closed because the author hasn't responded yet, it's his decision to make (allowing for his schedule and working around his life, when he has time to come back to this) -- not yours.

So yes, I'd call that rude on several levels, and will again ask you to refrain from doing so. (As opposed to, say, deleting your post when you do so -- not to put too fine a point on it.) Start your own topic instead of jumping into the middle of someone else's.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...