Jump to content
Comet Forums

listenport show green but slow download speed

Recommended Posts


i have a unlimited adsl 1mb account with a adsl 4mb line i installed the v1.19v of bitcomet it shows my listenport is green and open but if i download a torrent it is between 10kbps to 50kbps and on canyouseeme website it shows my port is open i phoned my isp and asked if they are blocking my ports but they say no what can i do i hade a other (capped) intenet account with same settings and it downloaded 10X faster please help me

i have windows 7

i have no anti virus for now

my modem is a telkom adsl5102g

the modem is in bridge mode

in the modem if it's in bridge mode there is no NAT support

my cable is plugged in my network card to my modem and from modem to the adsl (telephone)line

i have a pic off my bitcomet

Edited by pierre1985 (see edit history)
Link to comment
Share on other sites


That torrent either has no seeds, or you have not yet connected to any. That means that the torrent will never finish. This is a public forum so for your own safety hide your IP address and open port.

Look for another, better seeded torrent, like Open Office and see if you get better speeds. You also say that you don't have any personal firewall, is the one from windows active? If not you may already be infected.

Redo your bandwidth settings (in bitcomet/options/connection) to match your new connection, after you test your current speed at speedtest.net. Make sure your Global Max Upload Rate is set to at most 80% of your tested upload speed.

Link to comment
Share on other sites


yes there are seeders for that torrent but if i download a torrent with 10000seeders my download speed is 20kbps to 50kbps why i don't know

and yes my windows firewall is on with the settings applied to it i think it is correct

this is my speed test what must my download and upload speed be in bitcomethttp://www.speedtest.net/result/733362022.png


Link to comment
Share on other sites

Well, have you checked that your Global Max Upload Rate is capped to 80% of your tested upload speed, as Vasy told you?

(That would be around 24KB/s for the results you posted.)

Also I can see, that your torrent has 20 seeders and 2635 peers. In case most of them don't have many pieces of the torrent, that would result in very slow download speeds.

You should try, as Vasy instructed you, to download a very well seeded torrent (such as Open Office). If you get normal download speeds on that, then you'll have proof that nothing's wrong with your client and that the torrent was the culprit.

Link to comment
Share on other sites

You've set the firewall to accept ALL incoming connections for everything on your computer, that's equal to disabling it. That's why the warning prompts you to use the "Recommended settings"; click that and make a rule for BitComet, if you don't have one already.

Your speed test (and every ISP ad in the world) shows the results in bits/second, BitComet and usually any other network based client, uses Bytes/second(1byte=8bits). So, 0.97Mb/s=124.16kB/s and 0.24Mb/s=30.72kB/s.

Also, you have a limit of 40 connections per tasks, set that to a bit more (in bitcomet's advanced settings) and see if you encounter any problems, if you don't, you may keep it that way or increase it even more.

Link to comment
Share on other sites


okay i add more connections per task and downloaded open office my speed was 20 to 40 KB and can someone tell me step for step how to forward my ports on my router it's a telkom adsl 5102 g it's currently in bridge mode nat port mapping disabled and the firewall don,t know what to do i have tried the portforwarding guide from portforward site but no sucsess

Link to comment
Share on other sites

Are you sure that BitComet is the only app using your bandwidth? It might be an infection, too. Download dr. web cure it and set it to scan your whole system; it may take minutes..it may take hours to complete, so be patient.

Link to comment
Share on other sites


okay i forward my ports got the billion bipac 5102g (if you forward your port on this router you can't chose between tcp and udp)

now on the port forward checker (programe from portforward.com) they say my udp is open but not my tcp

please help

Link to comment
Share on other sites

let me go to the start

i have win7

i have a billion bipac 5102g router

the cable comes from the wall socket in the router and from the router to my network card

the problem is i have a 1meg account with a 4 meg line my speed must be 100kb to 150kb but is 1kb to 50kb

my upload is 24kb that is uploading fine sometimes going 1kb to 10kb but normally going 24kb

on PFPortChecker it shows my udp port is open but not my tcp but in bitcomet it shows all are open?

i have pics please go trough them and check for errors

i think i did a correct portforwarding















***Please use the spoiler code when you post so many screenshots at once.

It makes the post easier to navigate.***

Edited by greywizard
Added spoiler code for screenshots (see edit history)
Link to comment
Share on other sites

the main problem so far is this;

the problem is i have a 1meg account with a 4 meg line my speed must be 100kb to 150kb but is 1kb to 50kb

my upload is 24kb that is uploading fine sometimes going 1kb to 10kb but normally going 24kb

Sorry, but I do not understand that statement. Perhaps you should try rephrasing it. I can't figure out what you are trying to say, and what I can figure out seems wrong.

If your downstream bandwidth is 4 Mb/s then, converting, that would be 4,000 Kb/s, or in bytes, (4000/8) == 500 KB/s.

Where did your 100 to 150kb figure come from?

You are showing that you have at least one connection whose initiation is REMOTE. This is someone who did reach though your firewall, to initiate contact with you, via TCP. This is proof positive that your listen port is open to TCP. Moreover, this is the goal, it is what you are trying to accomplish -- to get those REMOTE initiations. All other indicators are just indicators, and to the extent that they say your port is blocked, they are demonstrably wrong.

Don't worry about the router, it simply opens the port to both protocols or none. I have never seen a home user situation where it made sense to allow TCP but block UDP at the level of the router. Somebody at Billion apparently thought it was silly to add this unneeded complication, too. About time.

That you are connected to the DHT network demonstrates that the port is open to UDP as well.

Link to comment
Share on other sites


what i wanted to say my internet line is from telkom our telekom supplier and that line is a 4meg line 4000kb downstream and 512 kb upstream

so i can go up to 4000kb but i have a account with screamer adsl that is only 1 meg i only use the telkom adsl line i can upgrade my screamer adsl account to 4000kb but i only got the 1meg account

okay i got my ports open it is showing green on bitcomet and utorrent but the problem now is if i download a healthy torrent with lot's of peers and seeders my download speed is only 20kb i wonder why

Link to comment
Share on other sites

For future reference, you needn't smudge the port numbers your client uses or the Size and Progress columns. This contain valuable information in many cases. Nobody can use them to link back to you or to hack your connection.

All you need to cover is your public IP and perhaps the name of the torrent.

Now, back to your issue.

Was this torrent just started when you took those screenshots of BitComet?

Because I can see that you're not uploading at all, and that your statistics tab shows 0 upload slots, which is being very odd. If you're not uploading than you're bound to get crappy speeds.

I'm intrigued and can't tell yet, why is your client not uploading.

I'd recommend, that you back up your tasklist, uninstall your client and delete all the remaining files in the Program Files\BitComet folder (if any) as well as in the Users\%userprofile%\AppData\Local\VirtualStore\Program Files\BitComet and in the Documents and Settings\username\Application Data\BitComet folder.

Then reinstall it, reconfigure the Options-->Connection page, settings with your current upload limit settings and give it a try again.

Also I recommend deleting all the BitComet/eMule entries which needlessly clutter your firewall and leave firewall configuration to BitComet. It does it dynamically for both ports and for both BitComet and the eMule plugin, and it even closes the ports after its exit.

Just make sure that the 2 appropriate options are selected on the Connection page, as well.

Link to comment
Share on other sites

  • 3 weeks later...

You should, as well, start your very own thread, instead of jumping into the middle of someone else's... it's considered quite rude, unless your problem is identical to the author's (the chances of this being the case, are quite slim).

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...