Jump to content
Comet Forums
hermonwong

My listen port is blocked, not because of firewall but because of UPNP

Recommended Posts

My listen port is blocked, not because of firewall but because of UPNP.

I followed the steps to unblock but it didn't help.

Overall Tasks: Total:114 / Running: 0

Listen Port of TCP: 26442 (Blocked by Firewall/Router)

Listen Port of UDP: 26442 (Blocked by Firewall/Router)

Windows Firewall: Added [TCP added, UDP added, TCP(ED2K) added, UDP(ED2K) added]

UPnP NAT port mapping: Failed [uPNP device not found!]

What does this means?

Share this post


Link to post
Share on other sites

It means you didn't read this first. What steps did you take to unblock it?

Also, there's this faq you should read.

Share this post


Link to post
Share on other sites

UPnP does not block ports. UPnP is a control scheme for peripheral devices, and that's all it is.

UPnP is basically a set of predefined messages and predefined effects.

A typical UPnP message sent to, say, a printer, might be, "UPNP SAYS TURN YOURSELF ON", and the printer, if it implements UPNP, knows to listen for that message and turns itself on in response when it gets that message. My printer does this. It's great, I don't have to remember to turn it on when I print. Other printers don't support that PART of UPnP, so they won't turn themselves on, though they'll do the rest of the commands.

"UPNP SAYS FEED A PAGE" and the printer ejects the current page, even if its blank.

A printer that does NOT implement UPnP, or does not implement that part of it, gets that message and just ignores it.

So, of course, UPnP can't block anything or do anything by itself, it's just messages sent to devices.

One of the kinds of device that it can control are routers or gateways which have built-in firmware firewalls, and those built-in firmware firewalls can block ports. But UPnP itself cannot.

BitComet told you, "your listen port is blocked." "I unblocked your listen port". You're good there, that's what you want. BitComet tells the windows built-in firewall to open your listen port when BC needs it, and to close the port when not.

Then BC tells you, in effect, "I can't open the door!" (Door not found)

Well, if there isn't a door, you don't need to have it opened. If you don't have a door, then of course you can't open the door you don't have! Doh! But this is what BitComet is telling you.

I couldn't use UPnP to map a port, because there's no UPnP device here. Doh!

  • Like 1

Share this post


Link to post
Share on other sites

So you're saying i don't have a UNPN thing.

Are you sure?

I've enabled Network Discovery on my laptop here.

Its called Network Discovery on Windows 7.

PLease help.

I followed the steps but I can't find the UNPN thing.

They call me do this do that.

And they say u can find the result at Control Panel>Network And Internet>View network computers and devices>....

There I can find the UNPN thing enabled but I CAN'T!

Share this post


Link to post
Share on other sites

Did you enable UPnP on your router?

It is not my colleague but BitComet which is telling you that it didn't find a UPnP device (not thing) and it means your router.

They call me do this do that.

Who calls you?

Are you working with 2 help teams at the same time?

Even if you have enabled UPnP use in BitComet and activated UPnP in your OS, it needs something to talk to (that would be your router). If it doesn't find it (i.e. you don't have a router or you have one but it has UPnP disabled) you will get that message, which is the logical one.

Since you didn't even bother to read and report the details Vasy indicated to you in the first link, stop complaining and asking for help because there is little anybody can do to help you unless you're willing to help yourself first.

Share this post


Link to post
Share on other sites

Hey, i fixed my problem.

I was so angry that my listen port is still blocked, I went and off my router.

When my router was on, I look at my Bitcomet.

My listen port is finally green!

Thank you all whether you directly or indirectly helped me.

Share this post


Link to post
Share on other sites

OK MY problem was fixed when i used another person's router.

Now I'm back at my home, where I recently applied for an internet.

I've tried port forwarding but it doesn't work.

1) What version of BitComet are you using?

v 1.25

2) What type of Internet connection do you have (ADSL, etc.)?

dial-up. Name's streamyx.

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

modem+router combo. Innacomm W3400V Wireless Modem. I'm from Malaysia. No.

4) If you have more than one router, be sure to mention the make and model of both devices, how are they connected (i.e. in which connector of both devices is the network cable plugged) and which one of the devices is connected to or is the modem.

Also, if you have more than one computer make sure to mention in this case, to which router is every one of them connected.

no

5) What version of Windows, Firewall and Antivirus do you use?

Windows 7, Windows firewall, Microsoft Security Essentials

6) If you are asking about a specific torrent or file that you have downloaded, make sure that you include the complete torrent name, as well as the complete names of the files and their respective extensions/formats (e.g.: .rar, .wma, .bin, .cue, etc.).

no

7) For speed-related issues, please run various speed tests at a site such as speedtest.net (make sure that no other computer is using your Internet connection and that all other programs - including BitComet - are closed, during the tests). Include the results, along with the settings that you are presently using, in your post, so that we may review and offer suggestions to improve its performance.

no.

I just want to fix my listen port.

Share this post


Link to post
Share on other sites

I've tried port forwarding but it doesn't work.

This you need to expand giving details about the steps you took and where you got stuck.

If you're talking about the same issue as above (automatic port-forwarding through UPnP) then I'll have to just quote my question from my previous post:

Did you enable UPnP on your router?

If you're talking about manual port forwarding you'll need to tell exactly what you did so far, and where you got stuck.

In detail.

Share this post


Link to post
Share on other sites

First you'll need to investigate/query your service provider. MOST wireless connections of whatever kind, are firewalled and the firewall isn't under your control. Your ISP won't assign you a static address and won't open a port for you. If this is your case, then you won't be able to get an open port and must operate in "no listen-port mode".

You've got to nail this down first, Are you firewalled by your provider, or not? If you are, there's no point trying to go any further with this connection.

Share this post


Link to post
Share on other sites

I think he means that he's wirelessly connected to the ADSL router not directly to the ISP. The device he mentions is a ADSL modem/router/wireless access point combo unit which obviously connects to the Internet through and ADSL line.

Share this post


Link to post
Share on other sites

TO BE HONEST.

I'm not very got at knowing information like unpn or whatever that other thing is.

Just tell me whats the next step and I'll do it.

And I'll tell you the result.

I've done what bitcomet told me to do but still my listen port is yellow.

I think its my router, i connect to other internet access via wlan it worked.

But when it come to my router, its yellow.

Share this post


Link to post
Share on other sites

Since you are being "honest"...

1. Until YOU describe in great detail, what specific steps you have taken, I'm afraid that you will only end up wearing the Staff's patience down.

2.

I'm not very got at knowing information like unpn or whatever that other thing is.

That's why Tutorials are offered both here and here - so that you can learn.

3.

Just tell me whats the next step and I'll do it. And I'll tell you the result.

I'm afraid that it doesn't work that way. You have to put forth a certain amount of effort, to help yourself, first.

4.

I've done what bitcomet told me to do

And what, exactly, did BitComet tell you to do? How, exactly, did you do it?

Share this post


Link to post
Share on other sites

Well, manual port forwarding is described in extensive detail in the second section of the port-forwarding guide on the BitComet Wiki, namely, the Manual Port Fordwarding guide.

If you would have followed the link Vasy gave you a few posts above, you would have read it already.

We ALL assumed that you DID read it. When someone asks for help and we provide a link we EXPECT that person to read it, because it's in her/his best interest. If s/he can't be bothered to do that... well that's their problem.

But your questions so far, were specifically about automatic port forwarding (through the help of UPnP) and that is also covered in the first section of the port forwarding guide on the BitComet Wiki.

Related to this, I've asked you if on the web interface of the router you have enabled UPnP or not. Somewhere, on one of the web pages of the web interface of your router you should have an option to enable/disable UPnP. That should be enabled if you wish to try using UPnP port mapping.

If you said, that you just needed your port opened, no matter what method we would have recommended you from the first time, the manual port forwarding guide.

Share this post


Link to post
Share on other sites

I hope you didn't follow that guide to the letter opening 40535 individual ports when BitComet only uses one(write the same number in the start and end boxes).

Also, this rule forwards the port to a specific private IP so you should also setup a static IP in your pc, or it'll change and you'll have a yellow light again.

Share this post


Link to post
Share on other sites

@ Wizard: Sorry, I know you're pissed at me. I did read but i didn't quite understand. Or maybe i missed some part.

@ Vasy: Thanks for your patience.

@ All: Thanks for taking time to help me.

Share this post


Link to post
Share on other sites

Look, you got it wrong. I'm not at all pissed at you. I'm just pointing out that when you solve your problems by guessing rather than trying to understand what goes wrong, you're prone to run again into the same issue sooner or later. That's what happened to you.

It's true, most users would like to just have an easy way to solve their problem, which entails no effort, fuss or learning process (who wouldn't?). But sometimes that's simply not possible; or if you keep "guessing" at it, you might get it to work in the end, but you'll never know what went wrong in the first place or what fixed it and the next time it happens again you'll be just as helpless as the first time.

There is ABSOLUTELY no shame in the fact that you didn't understand all of the stuff in the guide and that should never stop you from coming back and asking exactly about the things you didn't understand.

I, myself, have lots of other stuff that I'm still struggling with, so this was by no means me telling you to take a hike because you're not "schooled" enough.

When we point someone to a guide it's like pointing someone in the right direction. It doesn't mean that we're referring you to the guide INSTEAD of our help or that you shouldn't come back to ask for clarifications. On the contrary we like that; it shows that you really were interested in the subject and that you put some effort into it.

But once you've read the guide, even if you don't understand all of it, you will still get some part of it, won't you? Then when you come back here asking about the parts or stuff you didn't understand, we'll have some common ground to start the discussion from.

You wouldn't be totally clueless anymore (if that was the case in the beginning) but only about some part of the process, and that is a great improvement, even if you don't realize that at the moment.

It also happens to make our job A LOT easier, since we'll be talking about something we both know and instead of having to rewrite entire pages of instructions from the guide, we can only refer you (perhaps detailing the blurry parts) to a specific part of a guide.

I hope now you start to get the picture of what I meant. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...