Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Access to Download Folder renaming denied

Recommended Posts


I wish to rename the folder containing a BitComet download. For the sake of argument, let's say it is at "C:\Downloads\Torrent download".

I tried to rename the folder from "Torrent download" to, say, "Foo bar", using Windows Explorer. That didn't work.

So what I tried to do was using cmd.exe > Open as administrator, then: (1) cd C:\Downloads (2) ren "Torrent download" "Foo bar". It told me "Access denied".

My question is: Why do I not have access rights to rename the folder containing BitComet files despite being administrator? I suspect it is something induced by BitComet. If so, any way I can bypass it?

Thanks for any help in advance.

Link to comment
Share on other sites

When it comes to files, Administrator is really just another account, just another user.

A file has an owner. The owner has certain rights including saying who else can access the file. A file has an Access Control List that defines who can access it and how.

If the Administrator doesn't own the file and doesn't have a specific right in the file's ACL, then he can't perform that action. "Files" in this sense, include directories, but the ownership and access to the directory itself does not equate to ownership and access to the contents of the directory.

There is no "SysGod" user account which has all ownerships and all permissions to all files. This is pretty confusing to a lot of users. It's not at all a BitComet thing, this is pure Windows -- or really, pure computer science, since *nix has the same confusions.

The administrator does have certain automatic elevated rights when it comes to running programs, but not when it comes to accessing files.

Google the terms, "xcacls" and "subinacl". If you ever emerge from it, and can snatch the pebble from my hand, you will begin to understand.

Link to comment
Share on other sites

This is a windows user account problem, not a bitcomet problem. If you need help sorting it out, you're going to need to provide more information, and so far I don't even know what windows version your using, so I can't begin to help you.

I know windows XP used to protect the entire root of the C drive, so you need to enable full access to it in order to make any changes there, but you won't have any problem making your "foo bar" folder elsewhere then moving the contents.

Newer windows versions have more advanced file/folder ownership settings. It can get very complicated especially for folders made by windows installer, to delete them takes several very complicated steps, but as you probably noticed, when using *nix operating system, you can easily bypass all this file security, so the easiest solution might be to move all your files to a new folder, then delete the old folder from a linux or similar operating system.

Link to comment
Share on other sites

The question which nobody raised and which bothers me is: "Were you trying to rename the folder while BitComet was still running or while closed?"

If it was running, and the task is running then BC obviously locks the folder.

OTOH if BC was not running than indeed that's an interesting question and you should check with Process Explorer or whatever other app if any running process placed a lock on the folder.

Only if that's not the case then you should bother with permissions and ownership.

Link to comment
Share on other sites

You usually get a message telling you that the file is in use by another process when that's the case. While I can't recall exactly what the difference is, it's clear enough that I know whether to fire up Unlocker or dig into the ownership/permissions based on the message.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...