Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

I can't download anything with torrent with my new router


Recommended Posts

Hey guys

I've just make a new Internet with a new company

I have that portable mini router

with that router I can't download any torrents at all

even the torrents website won't open (like bitcomet.com , utorrent.com )

but when i connect to my old ADSL router

It downloads normally

and I've done the port forwarding thing many times

I'm 99% sure that I have done the instructions correctly but it still not downloading

and when I try my port in canyouseeme website

that's what come for me

Error: I could not see your service on **.**.**.** on port (54721)

Edited by fbmt2magic (see edit history)
Link to comment
Share on other sites

You may need to set a fixed ip number on your computer. In Windows, open a command prompt and type 'ipconfig'. That will show the ip address of the router which will probably be in the format '192.168.###.1'. Note that number and open then open network properties and go to tcp/ip v4 and, again, properties. Enter an ip number in the same format as the router but change the last number to something else. Your gateway will be the router number. If you know the DNS ip numbers for your ISP, use those, or use and (google DNS) and thewn try to connect.

Also, your ISP may have blocked some sites - if that's the case, use Firefox browser with the anonymox plug-in activated

Link to comment
Share on other sites

  • 2 years later...

Same issue here.

My Verizon-provided D-Link 2700B DSL router sucks (drops DSL often and WiFi sporadic at best).

Replaced it w/  Westell 327W (sadly, also stamped  "Verizon")

But it's a NOS  and the WiFi is many times  better.

No torrents will download through the Westell.

I reinstalled BitComet and -young ones shield your eyes-  even tried Bitlord w/same result.

Finally got to the Modem/Router  and my old one works fine.

I'm  Cometing along just fine now but want  the Westell.

Tried resetting  Westell no help.

Do I need a fixed IP address?


Link to comment
Share on other sites



You need a fixed intranet IP (that's the internal network, usually 192.168.###.1 for the router). Set your IP innetwork properties to the same block but with a different final number ),1 is normally the router). In the router settings, allocate a port number and set that to the IP number of the computer. Open Bitcomet and set the port number to match the one you just set up in the router (you can, if you like, set up a block of ports - like 12345 - 12356) but whatever port is open on the router MUST be matched by the port number in Bitcomet

Link to comment
Share on other sites

  • 2 weeks later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...