Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Listen Port Problem with BT Smart Hub & VPN

Recommended Posts

Hi, I've had a good long look on the forum but I'm no closer to getting the elusive green light. I hope I've included all the necessary info:

BitComet v1.47 (just the latest version I've tried as a fix), 64Bit, 

BT ADSL high speed (lol) broadband with Smart Hub Type A (no other make/model info on the Hub)

Home Wireless network

McAfee Total Protection on laptop (Acer Aspire E15) 64Bit, running Windows 10 Home, version 1709

IPVanish VPN

Situation is: Until late last year I was using TalkTalk ADSL broadband. Their wireless router didn't allow users to manage settings so I was using my Draytek Vigor 130 ADSL/VDSL modem plus a Belkin N+ Router. I had no problems connecting to BitComet servers. I had forwarded a port in the Router settings and added BitComet to the list of allowed programs in McAfee. Green light was go.

TalkTalk broadband was temperamental though, low speeds and kept dropping out when watching Netflix so I changed to BT High Speed ADSL Broadband (only have a telephone line, not cable enabled). Speeds are at least ten times faster but as soon as I swapped the hardware I had problems. Firstly, I could no longer connect to my media player (Popcorn Hour A-200, Cat-5 ethernetcable to router and wireless to laptop). In fact, the BT Smart Hub didn't 'see' the PCH at all. The ethernet port it's plugged into is showing as empty - I've moved everything around, tested different cables and it's still not visible.) I have access to the management area of the Hub and it seems like I can change settings but nothing helps on that front (perhaps that's for a different forum, but I thought it migt be relevant). 

Secondly, BitComet lost it's listening port (understandable with a new Router) so I went through the process of port forwarding but it's not worked this time. Just can't get it to work. Tried a static IP address and all the other recommended fixes but nothing works.

Since then I've set up a VPN account with IPVanish. Again, I've changed the settings as recommended, both on the VPN and also BitComet proxy settings but BitComet is still giving me a gray light.To re-iterate, whether or not I use the VPN, BitComet maintains a gray light status. I've tried uninstalling and reinstalling various different versions of BitComet based on various recommendations. PLUS, whereas before clicking on, for example, a Torrent file would automatically start BitComet, now it doesn't. It's like every Torrent link is dead. I've selected 'open with BitComet' for Torrent file types but that's had no effect. I'm starting to think that someone's out to get me!

Happy to provide any further info. Really want to sort this out as it's been months of fiddling around now...



Link to comment
Share on other sites

it sounds like you might have two routers, the hub and your wifi, then a third with your VPN. Did you reads the FAQs on wiki.bitcomet.com?  One of our former staff did a great job on setting up bitcomet on your network. I'd also stop using vpn until you get this sorted, maybe even use ethernet instead of wifi, then add and diagnose these additional networks one at a time. It's possible you have multiple issues, and all have to be fixed for the listening port to work.  


the port test is yellow if port is blocked, green if open, and grey if the test cannot complete. VPN often blocks connections to/from our test server, as can a firewall or IP filter.


Good Luck, and others should be by to offer more help

Link to comment
Share on other sites

  • 2 months later...

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...