Jump to content
Comet Forums

Can't get port to open up


Recommended Posts

Ok I use DSL. I don't have a router, I went into my modem and configured a TCP port for 18192 to be open for BitComet. I am still getting speeds that first of all fluctuate, but go no higher than 41kb\s

The speeds will climb to about 41kb\s stay there for a second and then drop back down to 1kb\s and then climb again. I had the same problem with Utorrent ( I like Bitcomet better ) but with Utorrent there is a tool to check if the port is open and everytime I go to check it after I port forward it still says the port is not open. I use windows firewall and yes I have opened it for bitcomet. I have an Actiontec modem. HELP PLEASE!!!!!

Link to comment
Share on other sites

Hi,

I am in the same case then sqwerchy, behind a router.

But, it is necessary to reforward the port in my router when I reboot my pc or I lose my Internet connection ?

However, the router port forwarding don't represent a security risk ?

I saw an very interesting option in BitComet :

Options->Advanced->Connection->Use NAT Transversal via UDP.

I hope that this option will be more efficient in next BitComet versions. :)

Excuse for my bad English.

Link to comment
Share on other sites

Ok, when you forward a port you do not loose it when your computer reboots, because its on the router.

No forwarding a port does not represent a security risk. Just run a good software firewall. Zonealarm & Norton are NOT good software firewalls. Windows XP SP-2 is a good firewall.

If you're worried about forwarding your ports then look your router up here: www.portforward.com.

Link to comment
Share on other sites

Ok, when you forward a port you do not loose it when your computer reboots, because its on the router.

No forwarding a port does not represent a security risk. Just run a good software firewall. Zonealarm & Norton are NOT good software firewalls. Windows XP SP-2 is a good firewall.

If you're worried about forwarding your ports then look your router up here: www.portforward.com.

1-I find this precision in the site www.portforward.com in how to have a static IP adress ? section:

"It is very important to setup a static ip address, if you are going to use port forwarding. When you have port forwarding setup, your router forwards ports to the ip address you specify. This will probably work when you initially set it up. But after restarting your computer, it may have a different ip address. When this happens the ports are no longer forwarded to your ip address. So your port forwarding configuration will not work." :blink:

In my case, I have DSL with PPPoE dial-up internet access mode (LAN), so I should build a dial-up connection (Bridge) in Widows XP (it is used to to establish connection to my ISP), so my question is:

To get a static IP adress, I should recopy my IP adress and Default gatway <router>.... informations ('IPconfig' comande) in "Intenet Protocol (TCP/IP)" Proprieties of "Local area network 3" (Win XP SP1), or in "Intenet Protocol (TCP/IP)" proprieties of my new dial-up connection build (pppoE protocol), or in both ???

2- I have another litlle question about the port forwarding:

It is necessary to forward the port in both TCP and UDP cases, or only TCP is sufficient, or it depend the router I use ???

Thenks again for your respenses :) (I hope that I was a little clear).

Link to comment
Share on other sites

Hi Jago,

I've just created a 'almost' whole guide on Portforwarding, have a look here:

http://forums.bitcomet.com/index.php?showt...view=getnewpost

There, it'll teach you how to make a static IP, and PortForward. It doesn't really matter what version of Windows you use, because the Portforwarding & static IP system is practically the same.

As for your second question, forwarding the TCP port forwarding should be enough. We tend to avoid touching UDP ports for torrent downloading...

Also, once you've forwarded your Ports once, you shouldn't need to do it again. Unless if you've just formatted your whole computer...

Link to comment
Share on other sites

Hello,

I don't yet know if my modem is also a router or no ???

I saw in "ipconfig" and I found that my "IP address" and "Default Gateway" adresses are always the same, and at every time I disonect/reconnect, I get a new one that is the same for the two ("Ip address" and "Default Getway"). :huh:

In addition, I try "default Getway" adress in my browser, but that don't give nothing.

So my modem is also a router or not ? if yes, how can I get my router web page adress ?

Thenks.

Link to comment
Share on other sites

If your computer's IP address and the Default Gateway are exactly the same then you have a modem.

In this case you dont need to make a static ip and you cant do portforwarding.

If the light in Bitcomets status bar on the bottom is green then theres nothing to worry about.

If its not green then maybe you have a software firewall blocking access, or maybe your ISP has you behind a proxy.

Link to comment
Share on other sites

You can of course try either disabling your Windows Firewall or adding BitComet to its exception rules.

Though, you may want to check your software setting, some firewalls such as Sygate may require you to also input a TCP port for applications in addition to just adding it to the 'unblocked list'.

@kolsa3a2004: I'm sorry, could you type in English?

Kind Regards

BitComet Team

Link to comment
Share on other sites

Hi all,

To begin, I want to tell you thenk you for all this explanations :)

So, I have trying all your suggestions:

-Yes, my ip adress (local ip) and the Default Gateway adress are exactly the same (10.10.xxx.x..), but I heve a second ip adress (external) 81.52.xxx.xx.(the x change). I found it with this link and BitComet log says :

Update Local IP: 10.10.xxx.x..

UDP tracker report: WAN IP = 81.52.xxx.xx.

-The light in Bitcomets status bar on the bottom is green ! and I have the Windows XP Pro SP1 Firewall only and I added BitComet in its exeptions (I tried to disable it also). But the problem is always the same, I have only 'local', very rarely 'NAT Travessal' and not 'Remote' connections. And my download speed average is 10k/s for an Uploading speed limit of 9k/s. My modem is HUAWEI SmartAX MT810 and I have USB ADSL LAN connection 128k.

-Some people told me that I am Nated by my ISP, so I must change my ISP. :huh:

Thenks for your patience.

Link to comment
Share on other sites

-Yes, my ip adress (local ip) and the Default Gateway adress are exactly the same (10.10.xxx.x..), but I heve a second ip adress (external) 81.52.xxx.xx.(the x change)

This means that your modem does NAT. I have a feeling that your local ip and the default gateway are not identical but very similar, check the last octet 10.10.xxx.xxx and make sure they are different.

In your modem/router you need forward the port that Bitcomet is using to your local ip.

I couldnt find your HUAWEI MT810 modem/router at portforward.com but try going through one of the other HUAWEI guides and see if it helps you set up yours.

http://www.portforward.com/routers.htm

Link to comment
Share on other sites

This means that your modem does NAT. I have a feeling that your local ip and the default gateway are not identical but very similar, check the last octet 10.10.xxx.xxx and make sure they are different.

No, they are identical at 100% !

Link to comment
Share on other sites

  • 1 month later...

After researching a little more you are correct it is just a modem so you cant portforward it.

Who is your ISP???

What mode do you have it in WAN or LAN???

Have you seen this page, maybe it will help you -> http://www.modemhuawei.com.ar/

@ bitdave,

Sorry to have taken as much time to answer:

-I think that my ISP is very unpopular in the world :unsure:

-My connection mode is LAN.

Thenks a lot.

Link to comment
Share on other sites

Jago, that IP address indicates that your ISP has you behind a router. The address block at 10.xxx.xxx.xxx is reserved for private networks, and never publicly assigned. That you have a different external IP confirms this.

It basically means your ISP has you behind a firewall which you don't control, so unless you have one of the world's most cooperative ISP's, there's nothing you can do about that situation.

You can try using some commonly-used-for-other-things port as your listen port, though this may not work either and isn't a good idea in a lot of situations. Try using port 8080 and see if that works. If not, and you're not using MSN messenger, try 6901. If you're not using Skype and don't run a web server, try 80. If nothing else works, try 25, though this may make your antivirus software complain about email activity.

Just in case this isn't clear, whatever port you try needs to be open on your own firewall too. And don't forget to close the ports you've tried which don't work.

And if you do change to an ISP that isn't blocking everything, stop using any of those ports, because that can create problems.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...