Jump to content
To block spammers, this forum has suspended new user registration ×
Comet Forums
To block spammers, this forum has suspended new user registration

Data loss issue


Recommended Posts

Dear all,

Many users have experienced the data loss problem, their downloading progress has dropped to 0%, and the downloaded file became unavailable.

The development team is working on this problem and hoping to find out the solution ASAP. We are sorry for any inconvenience caused. If you are also experiencing this issue, please provide the following information to help us solving the problem. :)

1. Your operating system

2. BitComet version

3. When did it happen

4. Did data loss happen to all the tasks in tasklist or some of them?

5. How did the problem happen? What's the size of the task? And the progress before data loss?

6. Were there more than 50 files contained in the task?

7. If you don't mind, please show the log and magnet link of the torrent.

Since most error occurred after hash-check, please DO NOT hash-check your other tasks, just in case the data will be dropped. If you are using version 1.23, 1.24, or 1.25, we also suggest you to switch to version 1.26 or 1.22, in order to prevent auto hash-check when starting BitComet. If youd like to upgrade to v1.26, please go to options -> Advanced, change the value of bittorrent.hash_check_if_file_changed to false.

Thank you for your support,

The BitComet Team

Link to comment
Share on other sites

win 7

BitComet 1.25

Lossed data between 16th feb and 19th of feb completed 4th avi file an avi on 16th of feb played good completed 5th avi on 19th feb would not load said 100% did a hash check dumped from 82.6 complete on all files yo 11.5% with first 5 avi files which were complete reading 0%

Data loss happened to all files 13 jpg and 13 avi incoplete files will not load preview using mpc star appear to be corrupted

total of 26 files


manage to restore 4 completed avi files by restoring previous version from win 7 can probably do the same with jpg's incomplete files with bc extension appear corrupted but have a % beside them

Link to comment
Share on other sites



* Data loss between 18th Feb to 20th Feb'11 after 1 completed bluray rip file. I tried to open the completed file but there's nothing & also same thing happened when i try to check the preview of all my uncompleted bluray rip &

mp3 files. My size task is around 1.20gb - 2.50gb per file & when data loss happened, there's 6 files downloading & all were affected.

* There were 25 files contained in the task but only 6 files were active during the incident.

* I have deleted all the unfinished tasks, re-install bitcomet 1.26 & try to re-download the files which I've deleted from the previous tasks.

* Is it advisable for me to carry on with my downloading or wait until the problem solve before i can use bitcomet again??!!

* p/s. how to show the log and magnet link of the torrent ?!!

Link to comment
Share on other sites

1- Windows Vista Home Premium 32bit

2- BitComet v1.25 and v1.26 (I upgraded and it happened again)

3- I believe the first time was 15 February (I had it happen three times)

4- Every file in two tasks (the first time, and in three the second and third time) went to about 1% (it seems as though the bit that consists of the very beginning and the very end of each file is all that remains), however every other smaller task I was running continued to work fine.

5- It happened when I had a crash of BitComet. When I restarted two of my files reported at 100%. I knew this to be an error because there were at about 60% of 17.65GB and 80% of 59.90GB an hour earlier. So I ran a manual hashcheck and it said all the files were at about 1%. The third file corrupted the second day (no hashcheck was run during of after this corruption) that file is reporting at 54.3% of 37.40GB but I cannot view completed files or preview partial files.

6- The first task has 26 files, the second has 175 files in 7 folders, the third 111 files in 5 folders.

7- the three different tasks:




I had another large download that I was running that did not corrupt. It was either a lucky task or it has something to do with disabling files, as the first three had files disabled and this one did not.

Edited by merlin97501 (see edit history)
Link to comment
Share on other sites

I have been testing my theory on disabling files. When I disabled all but one season of a show on one task and downloaded for a while I was able to preview some episodes. After turning off my computer for the night and restarting it, I found I could no longer preview those episodes I could before. Running a hash check confirmed that those files had gone back down to about 1% each. I then tried downloading the same task with nothing disabled. After several days I was still able to preview the partial files. I ran a hash check anyways and nothing changed and nothing corrupted. All the files were at the same percentage before and after the hash check.

I have no idea about the programming so this is just a random thought: I've noticed that in past versions of Bit-Comet when file "A" was disabled, you downloaded the one next to it, file "B", then enabled file "A", and completed it. If you ran a hash check once both files were complete, the 'bit' that is shared as the end of file "A" and the beginning of file "B" would occasionally be found missing with in the hash check. In more recent versions of Bit-Comet, this no longer happens. Since in this current problem, the files seem to revert to just that shared 'bit' in question, I thought of this change. Again, this is just a shot in the dark, but maybe whatever was changed in the 'disabling files' code concerning the beginning and end of files may be responsible for our current problem.

Edited by merlin97501 (see edit history)
Link to comment
Share on other sites

maybe whatever was changed in the 'disabling files' code concerning the beginning and end of files may be responsible for our current problem.

Thats one theory I was thinking too. Most users don't realize that bittorrent protocol doesn't download the files and they exist, it breaks the files into equal size pieces then after being downloaded they are reassembled into the initial file structure. Some users have decided its more efficient to download one file at a time, which is the most inefficient way to download a torrent. It makes you a very unattractive trading partner, because you will reject most pieces offered to you, and only request very specific pieces that may be extremely rare at the time you wanted them. Since users were misusing this feature, it caused bitcomet to change the way it handles disabled files. Older version "correctly" (in my opinion) would delete a disabled file, but after getting reports from users that didn't understand why a file that was disabled was also deleted, so bitcomet was changed and now leaves the previously downloaded but deselected pieces there. I think a better solution would have been to put a warning that disabling a file will delete it would have been far better. For one thing, if a file is disabled, it will no longer be shared, so doing this will make you a less attractive peer, and harm the entire swarm.

I can't say if this is related to the dataloss problem or not, but I think I would look for a more simplified way to handle selection of files, perhaps making it impossible to deselect a file that has completed download. What would really be the best solution would be if users would simply just download torrents as they were meant to be downloaded, and not try to change things because it usually only harms themselves and any peers they are trading with.

Link to comment
Share on other sites

Well, merlin97501, thanks for sharing that. This is quite an important piece of info as it confirms the suspicions some of us had. I hope the team may be able to reproduce this now, perhaps.

Since you've been able to reproduce the issue, would you care (if you find the time, of course) to downgrade to v.1.22 and check if you encounter any similar issues with it or not?

(You actually needn't really uninstall your current version if you don't feel like it, you can simply download the ZIP version, de-archivate it in a folder of your choice and start the executable. Just make sure that the other copy of BitComet that you have currently installed isn't running.)

This would help narrow this down even more, as we could report back to the team that it's a change in the code which happened since v.1.22 which triggers the bug.

Link to comment
Share on other sites

Hi guys,

Just adding a little information about the data loss problem.

When the problem occurred, most of the files in my torrent weren't disabled.

I only disabled files that I absolutely do not want (like the 10 txt files containing promotion links or what places has the torrent been).

In any case, the problem seemed to have gone away by itself maybe a couple days ago :huh:

I didn't do or change anything (except for regular windows automatic updates)

Link to comment
Share on other sites

I was trying to recreate the corruption so I disabled a bunch of files in a task, downloaded for twelve hours, turned off my computer for a night, restarted and checked. Nothing had been corrupted. I ran a hash check and still nothing corrupted. Everything worked normally and I was unable to confirm my theory.

I downloaded Bit-Comet v1.22 and I'm running a couple tests using that. However, since I was unable to recreate the problem using v1.26 I can't really prove anything.

It is odd that this problem hit several people during one week and then just went away. Were this truly a problem with the code, it would have appeared soon after the change to the code and continued. What else could have caused it?

Link to comment
Share on other sites

What we actually need isn't "not many files", but "no files". IOW, is having one or more files disabled, a necessary part of recreating this defect? Or does it occur with all files enabled? This will guide the programmers in where they need to look.

So far, we are guessing that it requires a fairly rare combination of a fairly large torrent (how large, we don't know) and some of the files in that torrent disabled. We are looking for (and trying to create) examples that fall outside of those conditions, which would prove we're wrong about it.

However, under NO circumstances is data loss ever acceptable to us.

Link to comment
Share on other sites

I agree, it seems quite the mystery. I'm starting to wonder if there is some kind of other piece of malware going around that is causing this problem and it's only surfacing in bittorrent downloads because of the frequent use of the files. This is only pure speculation though.

All members keep posting any issues and we'll find the problem, if it does exist.

Link to comment
Share on other sites

I only disabled files that I absolutely do not want (like the 10 txt files containing promotion links or what places has the torrent been).

Off topic for this discussion but I thought I'd mention that by disabling these tiny txt files your most likely not reducing the size of your download and you are adding a lot of complication to the proceedure. Each of these files is included in a piece of data that you most likely NEED to complete other files that are enabled, so by diabling the txt files your only causing a lot of complication, and in some cases you won't achieve full seeding status if you don't download all the pieces. It would be far better to just let the harmless small files download then delete them after you have finished seeding the torrent.

I understand common sense tells you not to download a file you don't want, but bittorrent doesn't download file by file, it downloads piece by piece, and each piece can have parts of files within it so your just making BitComet work harder since it has to still download the file by hide it from you (so to speak).

Disabling files within a torrent is the most abused feature in bittorrent. It was never designed to do this and this feature should only be used in specific cases, such as a torrent of 20 episodes of a tv show where you only want some of them, and you should never downlaod a torrent one file at a time in this case. Only disable files if you NEVER want it downloaded. Disabling files because you want to wait and get that file later will harm the efficiency of your downloads and the entire swarm.

I also don't like the file priority settings, they too are abused. I think it would be reasonable to download the 20 episodes and set the first 3 to high priority, so you can watch them first while the rest download, but the most efficient way to download them is to get the pieces that are offered to you. If you force your client to be selective, you will pass up a lot of pieces being offered and increase the overhead required to do the downloading, making it less efficient and in turn making you a lesser peer (harder to complete transactions with). If you leave all files to normal, then you will accept all offers for pieces you need, and make you a better peer and in turn get you connected to better peers.

Link to comment
Share on other sites

1.Window 7 Ultimate 32-bit operating system

2.Bitcomet 1.25 when the problem occurs, after upgrade to 1.26 the problem remain

3.Around Feb 18, i use ver 1.25 since last year, 1st time face this problem

4.The files that already finished download in a task is still remain there without any problem playing them. Just the task progress reset to 0%

5.I let the PC stay overnight for my download, in the morning the task progress reset, i found out some of the task is shown completed but the files are not yet complete

6.Files inside the task is not more than 50, the size is around 1G to 2G+. Last time i even download larger file but no such problem been shown.




Hope this can help you guys to improve Bitcomet. Thanks for the help.

Link to comment
Share on other sites

Unfortunately, nobody from the development team (neither among us) was able to reproduce the issue at least once so far. Neither have we encountered or heard about this one before. It pretty much came out of nowhere.

And as you know it's impossible to trap a bug and begin debugging until you can actually reproduce it in a repetitive manner.

That's why we still try to find out some condition which may trigger that behavior in a mandatory fashion.

But we've been out of luck so far.

Perhaps, re-trying with the same task on which you encountered issues before and v.1.26, would bring you an inch closer to re-creating the same conditions. That is, if you feel like testing some more.

Link to comment
Share on other sites

@The Unsual Suspect: Thanks for that info, I actually never thought of it that way :o

@greywizard: To me the most peculiar thing about this whole problem... is that a lot of the users started to have the error roughly the same day.

Link to comment
Share on other sites

Hey Suspect,

I have had data loss and it was in the same time frame as most of the other complaintant's. I think there is one or more torrents that are carrying a virus...the data loss I experienced deleted ALL of the torrent files I had dnloaded including those I had "sent" to zip files and files I had sent to my flash player. These files were no longer in BitComet files...I ran malwarebytes and found a "WhitePup" in my bios system that was NOT there previous to the day in question. I then ran a Sophos program and removed it...no problems since.

P.S. this particular virus does not exhibit symtoms, such as error pages or locked windows...very sneaky

Link to comment
Share on other sites

Actually kluelos, lets not assume it's not related.

Will_takum, can you clarify your report please. When you said it deleted all your torrents, do you mean the tasks disappeared? or the level of completion reverted to 0%? I'm also unclear what your reporting in regards to files you sent to zip files and sent to your flash player. The terms and language your using isn't such that we can understand exactly what your saying. We are grateful that your trying to report your experience, but can you better describe the entire situation.

Additionally, can you give us more details about the malware you found on your system. You refer to it as a virus, but if it's a "pup", then it's not actually a virus, it's a "potentially unwanted program". The software that detected it will usually have a webpage that describes it in detail, so any information you can add may be of use, but as kluelos mentioned, your case may be unrelated.

Link to comment
Share on other sites

It may be related, sure, but it is not the behavior that we are trying to pin down and duplicate. If we start dissipating our efforts over every issue that could have something to do with it, we may never get to a clear and definite defect that can then be resolved.

So far, nothing that anyone else has reported has had any effect whatever on the .torrent files themselves. There's no reason to believe this is related, but *everything* might be. That doesn't help or get us closer to isolating the problem. I think we should treat this as a different issue until there's a definite reason to think otherwise.

Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now
  • Create New...