Jump to content
Comet Forums
MrYumYum

new router, bitcomet cant listen to ports

Recommended Posts

hello, i just bought&configured a new router (d-link DIR 655) now every time i try to change a listening port it says: "can not listen to port:", using my old router i got a green light..

things ive done so far: port forwarding, binded my pc's ip (the ip it gets from the router), made an exception for bitcomet on my avg resident shield, cannot find an exception list on the avg firewall window, windows firewall is disabled

1) What version of BitComet are you using?

1.21

2) What type of Internet connection do you have (ADSL, etc.)?

cable 5mbit

3) Do you have a modem? Do you use a router? What make and model are each one of them? Have you forwarded your port?

motorola modem (cant remember the type, too lazy to go downstairs and check.. i think it was sb5100 or something), router stated above, ports are forwarded

4) If you have more than one router, be sure to mention the make and model of both devices, how are they connected (i.e. in which connector of both devices is the network cable plugged) and which one of the devices is connected to or is the modem.

Also, if you have more than one computer make sure to mention in this case, to which router is every one of them connected.

have 2 pc's, am using bitcomet only on one of them, both connected to the router

5) What version of Windows, Firewall and Antivirus do you use?

windows 7, windows firewall disabled, avg firewall+antivirus ver. 9.0.837

6) If you are asking about a specific torrent or file that you have downloaded, make sure that you include the complete torrent name, as well as the complete names of the files and their respective extensions/formats (e.g.: .rar, .wma, .bin, .cue, etc.).

irrelevant

any ideas??

thanks in advance,

IdanP

Edited by MrYumYum (see edit history)

Share this post


Link to post
Share on other sites

We see this pretty frequently. The usual cause is that you have already started an instance of Bitcomet, or one has autostarted at boot, and you aren't aware of it.

The first instance registers the listen port with Winsock. Then a second instance starts and attempts to register the same port, which Winsock does not permit, This error message is generated.

Changing the port doesn't help, because this merely changes the port for both instances.

Check your preferences/options/whatever to see if BitComet is set to start with windows. If so, then examine your other settings such as "minimize on startup" to determine what it's doing -- it may be starting up and staying in the system tray where you don't notice it.

Check also to see if you have BitComet contained in your program menu's startup folder.

I use a utility called "autoruns" from Sysinternals.com, to determine what programs run at windows start. I don't know whether or how well it works with Win7 though.

Share this post


Link to post
Share on other sites

thanks for the quick reply,

unticking the "auto-start with windows" box is the first thing i do every time i update my bitcomet

just to make sure ive checked the process list on windows task manager and just 1 bitcomet line appears there

edit: just found out router has a firewall, can this be the cause?

Edited by MrYumYum (see edit history)

Share this post


Link to post
Share on other sites

The purpose of portforwarding is to get your remote connections past your routers firewall, so if your router is setup correctly, then you won't have this problem.

It's very likely you've made an error setting up your portforward. If possible, bypass your router and connect direct to your modem. If that fixes the problem, then you know your port isn't forwarded correctly. If it does not fix the problem, then you know it's the settings on your computer that is blocking the port.

Share this post


Link to post
Share on other sites

That particular error, "cannot listen to port" usually means not that the listen port is blocked, but that something else has already "grabbed" it, registered with Winsock to take the traffic on that port. That is assuming that this error is coming from Windows itself. If it's coming from the router firmware, it probably means something else.

BitComet won't generally throw an explicit error for a port that's simply blocked.

You can use another sysinternals.com tool called "Process explorer", which is similar to Task Manager but quite a bit more flexible, to see what processes are actually running, and whether you've already got an instance of the client running. Failing that, you'll need to figure out what's grabbing the listen port first.

Unfortunately, I don't know of a tool that will simply list ports that have been registered.

Share this post


Link to post
Share on other sites

Typing "netstat -n" (without the quotation marks of course) at the command prompt, will return all the TCP sockets in use at that moment in numerical form (instead of NetBIOS names). If you add the "-a" switch it will display UDP sockets as well.

By adding the "-b" switch you'll also be able to see the local executables which uses those sockets.

Share this post


Link to post
Share on other sites

The UnUsual Suspect

when using modem only i am getting a green light, i know its something from my pc since it worked fine with the old router it has to be something about this router..

just that i dont know what else to do other than forwarding my ports..

kluelos & greywizard

heres the list of tcp sockets using "netstat" (ones from my current bc's listening port), i have no idea what im looking for here

tcpw.jpg

cant find udp (netstat -a presents tcp sockets as well)

Edited by MrYumYum (see edit history)

Share this post


Link to post
Share on other sites

If you use the "-b" switch as well you'll be able to see the process that uses that connection along with the socket. Therefore you can determine if it's BitComet who's using the port or not and thus confirm or eliminate the cause kluelos brought up.

I'd have to say that I don't remember having seen yet this type of error. Therefore I have to ask:

Where and how does it appear?

Is it in BitComet or in Windows?

Can you post a screenshot?

Share this post


Link to post
Share on other sites

sorry for not making myself clearer, heres a screeny:

bcerror.jpg

it happens when i try to change my listening port (i do this every once in a while since i believe my isp is blocking it after certain time of downloading), so basically i just change the port, press apply and get this message

Edited by MrYumYum (see edit history)

Share this post


Link to post
Share on other sites

Does it happen with every value you try for your port?

You should use values from the 49152 - 65535 range, since those ports are more unlikely than any other value, to be already registered by another application or blocked by ISP.

Share this post


Link to post
Share on other sites

Hmm... if you say that you get a green light with your older router, this points toward a misconfiguration in the forwarding settings.

You should check this guide (Add Port Mapping in NAT Router) (the manual forwarding part) and use it to retrace your steps and see what you missed or did wrong on your new router.

Share this post


Link to post
Share on other sites

I agree, you either have an error setting up your portforwarding, or perhaps a defective router design. I'd see if there is an updated firmware for your router, then retrace your steps, it only takes one wrong entry to cause the problem.

ps. Your old router most likely better supported universal plug n play (uPnP) standards, and bitcomet was able to open the port for you. That would explain why it worked on your old router.

Share this post


Link to post
Share on other sites

thanks =], ill give it a shot

regarding the router's firmware i already checked, this is realy dumb there are like 4 newer ones that if i were to install them my warranty would be voided (since i dont live in the US but in Israel they only support my current version of firmware, the one i got with the router)

Edited by MrYumYum (see edit history)

Share this post


Link to post
Share on other sites

Well, I certainly don't want to tell you to do something to void your warrenty, but in the unlikely event you do have a warranty issue, you could always reinstall the old firmware, assuming the unit will boot up and install, and if it doesn't, it's unlikely they would even look into fixing it. These things are usually just tested when returned, dead ones are trashed and working units are sold as recertified/refurbished.

At least where I live the cost to repair is much greater then the cost to replace.

Share this post


Link to post
Share on other sites

well i upgraded my firmware, reconfigured everything with the minimal security possible, forwarded my ports again using the guide you've posted (which was the same as i did before) and binded my LAN IP, re-installed bitcomet, tried UPnP thingy and i still get this "can not listen to port" warning every time i change them.. btw heres a screeny of the forwarded ports so u'll know there is no room for making mistakes there:

portfo.jpg

im thinking of re-formatting though im not sure if its worth it..

edit: just checked to see if ports were realy closed using pfportchecker, it says they are not for tcp however they are open for udp (checked all 5 i forwarded)

does this mean anything to you?

Edited by MrYumYum (see edit history)

Share this post


Link to post
Share on other sites

Please use only one port, the port that you have set bitcomet to use, making a rule for tcp and one for udp on the same port.

Also, when changing your port in bitcomet, you should restart bitcomet for it to properly open your router/firewall.

If your still unable to get the port open, check the guides at portforward.com. They will walk you through the whole procedure step by step, with screenshots.

Share this post


Link to post
Share on other sites

Please use only one port, the port that you have set bitcomet to use, making a rule for tcp and one for udp on the same port.

Also, when changing your port in bitcomet, you should restart bitcomet for it to properly open your router/firewall.

If your still unable to get the port open, check the guides at portforward.com. They will walk you through the whole procedure step by step, with screenshots.

already done that, though i sometimes get the green light, most of the times its yellow and i only get it after restarting bitcomet.. i think its only momentarily open since whenever i check it with pfportchecker it says it is blocked..

Share this post


Link to post
Share on other sites

The port won't suddenly start being blocked for no reason unless your router is defective somehow.

The bottom line test is presence of remote peers. Also, you can test your port at canyouseeme.org. It's a simple test and leaves no room for user errors that a software application can. Make sure bitcomet is open and running when you do the test, and once your port is open, don't change it. Doing so will block incoming connection attempts for upto an hour.

Share this post


Link to post
Share on other sites

well it says my isp isnt blocking the current listening port on bitcomet.. i thought we were checking to see if my router was blocking it??

Share this post


Link to post
Share on other sites

If the light is green, then the port isn't blocked.

Share this post


Link to post
Share on other sites

There is no issue with the router. This is a bug with 1.21

BitComet issues the message, "Can't listen to port:nnnnnn" when the designated listen port has already been reserved by another application.

BitComet does not issue any error message at all when the port is merely blocked by a firewall, internal or external.

Recreate this error:

  1. Start µtorrent.
  2. Change µtorrent to use port 65432
  3. Change BitComet to use port 65432. It will complain that it cannot listen to port 65432. Dismiss this complaint.
  4. Shut BitComet down completely.
  5. Restart BitComet. It will complain that it cannot listen to port 65432. Dismiss this complaint.
  6. Change BitComet to use port 65431. It will now complain, just as stated, that "BitComet cannot listen to port" with no number stated.

Voici, l'erreur

  • Shut BitComet down again.
  • Restart BitComet. No error this time.
  • Change to a port you know is blocked
  • Restart BitComet. No error. BitComet does not issue an error for a port that is merely blocked.
  • Install 1.20 and repeat steps 3-6.

Voici, l'erreur disparaît

Share this post


Link to post
Share on other sites

OK then, Lucy, can you report this to the team, please?

Share this post


Link to post
Share on other sites

Sure! Thank you guys! ;)

P.S klulos, what do "Voici, l'erreur" and "Voici, l'erreur disparaît" mean??

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...