Jump to content
Comet Forums
wingnutta

Downloaded files missing their extension?

Recommended Posts

This helped me if ur using Windows go to Folder Options / View, uncheck "Hide extensions for known file types" and click Apply

Edited by nenadd1 (see edit history)

Share this post


Link to post
Share on other sites

This helped me if ur using Windows go to Folder Options / View, uncheck "Hide extensions for known file types" and click Apply

this is a completely different issue. but yes it can resolve a issue of you not seing the extention. once the file is downloaded. however the issue raised here is of the magnet url not resolving correctly once bitcomet downloads it and downloading an incomplete filename. FOR EXAMPLE THE FILE EXTENTION NOT BEING ADDED so thanks again please read the post with pictures. and ull understand.

Share this post


Link to post
Share on other sites
bC often took a while to get the details and sometimes appeared to hang for a few seconds while it aquired the details

The delay you speak of is normal, since BC has to search the DHT network and download the .torrent file before displaying any info about the task. This is because the magnet link doesn't contain filenames, just the name of the torrent and perhaps tracker URLS. Therefore, before downloading the .torrent file, BC cannot know anything about the task type (single-file or multi-file) and filenames. While the delay may be justified, since sometimes it may take querying DHT nodes much further from your client, if the .torrent files isn't found in the first queried nodes, the hang up isn't normal and that may be a different bug in itself.

Anyway, the issue discussed above, lies in my opinion entirely in the coding of v.1.32 which probably may be bugged, and doesn't implement in the task properties what it reads in the .torrent file, from the first time.

Share this post


Link to post
Share on other sites

Wow - didnt realise my small problem was such an issue. I did forget to say that it all started with magnet links - my bad - sorry! I still have the problem but i just notice what the file extension is and just add it to the filename. No big deal - as has been said - more of an annoyance! If it gets fixed then great - if not.. now worries!

Share this post


Link to post
Share on other sites

This topic is a little old but this is the exactly same problem that I'm having here.

Same thing as the others, started when I got to 1.32 and only with magnet links, BUT I also noticed that it only happens with "loose" files, like all of the EZTV files. If you download a FOLDER with the files in, the extensions appear how they supposed to. Don't know if I made myself clear here 0o

It's only a pain is the a** when I forget/don't know wich is the ext of the file I've downloaded. Most of the time I just rename it and it's done. No one's gonna die because of it.

Share this post


Link to post
Share on other sites

I noticed this issue a long time ago, but found a fix of sorts.

When you download a magnet link on the EZTV homepage the first time on any episode, the the bitcomet new task box does not show the file extension in the filename line. You have to cancel and re-download the same magnet link a second time to get the extension shown properly.

But this " download twice" issue only affects the magnet links on the homepage and show information pages (and most magnet links I download. Pirate bay etc). The magnet link on seperate episode pages download perfectly on the first attempt. Any of you can try out this method and see if it works for you. ( I havent tried on another computer.) I dont know if this a website problem or a bitcomet problem. I'm always hoping this will be fixed in a new version of bitcomet, but its been like this for the last few versions. I hope somebody finds out what the problem is.

btw,,,,,I dont condone piracy & EZTV was the best way of explaining the problem and solution. Hope this helps.:)

Share this post


Link to post
Share on other sites

I noticed this issue a long time ago, but found a fix of sorts.

When you download a magnet link on the EZTV homepage the first time on any episode, the the bitcomet new task box does not show the file extension in the filename line. You have to cancel and re-download the same magnet link a second time to get the extension shown properly.

But this " download twice" issue only affects the magnet links on the homepage and show information pages (and most magnet links I download. Pirate bay etc). The magnet link on seperate episode pages download perfectly on the first attempt. Any of you can try out this method and see if it works for you. ( I havent tried on another computer.) I dont know if this a website problem or a bitcomet problem. I'm always hoping this will be fixed in a new version of bitcomet, but its been like this for the last few versions. I hope somebody finds out what the problem is.

btw,,,,,I dont condone piracy & EZTV was the best way of explaining the problem and solution. Hope this helps. :)

That worked out just fine! In TPB too.

Tnx!

Share this post


Link to post
Share on other sites

I have been having this problem for awhile and finally it annoyed me enough to google it, ended up at this topic, what i have found supports what BlazeSeven1 said.

the front page magnet links are different than the show details page's magnet link.

for instance an episode of the glades has this on the front page

magnet:?xt=urn:btih:N6HXYOGF2LQMWD5N6MWIB7ZY5VBQ5JTC&dn=The.Glades.S03E08.HDTV.x264-2HD&tr=udp://tracker.openbittorrent.com:80/

and this on the details page

magnet:?xt=urn:btih:N6HXYOGF2LQMWD5N6MWIB7ZY5VBQ5JTC&tr=udp://tracker.openbittorrent.com:80/

clearly the front page is including the name of the file without file extensions, the second link allows BC to download it as normal with the extension intact.

so i guess my next step is to fire off an email to eztv and see if they can adjust their magnet links on the front page.

Edited by kwedo (see edit history)

Share this post


Link to post
Share on other sites

This still may be a bitcomet issue, but all we can do is wait for the development team to issue an update, in the meantime with a bit of patience you can easily use either magnet link.

Share this post


Link to post
Share on other sites

I have the same problem and is a BitComet problem. The problem occurs when you try to download a single file torrent. BitComet takes the torrent name as filename instead of the name of the file.

Using bitcomet 1.32 on magnet link, single file download. Windows 7 x64

Edited by Seraph64 (see edit history)

Share this post


Link to post
Share on other sites

That is pretty much what has been said. Not much profit in repeating it.

Share this post


Link to post
Share on other sites

Anyway, the issue discussed above, lies in my opinion entirely in the coding of v.1.32 which probably may be bugged, and doesn't implement in the task properties what it reads in the .torrent file, from the first time.

wow - bitcomet acknowledges it is their error - that's a good first step for solution.

Share this post


Link to post
Share on other sites

And the best second step would be actually fixing it. This error/problem prevents users from previewing a video download in progress. Major bummer, and the ONLY reason I use bitcomet.

Share this post


Link to post
Share on other sites

And the best second step would be actually fixing it. This error/problem prevents users from previewing a video download in progress. Major bummer, and the ONLY reason I use bitcomet.

If you pay attention when you start the task this can be avoided.

Share this post


Link to post
Share on other sites

If you fix your program that has been broken for several months now, this can also be avoided. Thanks!

First of all it sounds to me like your complaining about a free product, when I see you develop an application and share it freely with the community, then I'll respect your right to complain, until that day I must say it sounds very rude to me... but that's just my opinion.

Second, it's not "My Program" to fix, just like everyone else here I volunteer time to help people and I just spend some of my valuable time to point out to you that this can be easily avoided by paying attention when you start the task, so the problem is little more then a minor annoyance and I haven't seen you lift a finger to help anyone here, only to complain.

Third, if you can't show kindness and respect to other bitcomet users who volunteer time here to help you, then you won't be welcome in the forum.

Lastly, as I pointed out, it's very easy to catch this when the task starts and fix it so you CAN preview the content during download.

Now please think long and hard if you want to be part of this community of bitcomet users. We are here to help each other and members who only gripe and complain about a free product are not only rude, but they ruin the friendly atmosphere and fellowship that the greater filesharing community has created. If you want to complain about a free product, go contact the developers directly, you can email them or join their forum and speak to them in their language, but if you want to be a member here then perhaps you can find something positive to contribute.

To sum it up as succinct as possible, you can play nice, or you can leave... voluntarily or otherwise.

Share this post


Link to post
Share on other sites

I just wanted to let you guys know that I have also been having this issue ( it does seem to be happening with EZTV downloads. The magnet link pop up window displays the information correctly ( i.e. file name etc...) but for some reason the extensions are still missing when the file is downloaded. If you will remember, this was happening a year or so ago after bitcomet was updated. Not saying what is causing this issue, but I am going to say that The Usual SUspects reply that this is not happening to others was a little out of line. I usually agree with your posts, but you really do have a bit of an attitude on here sometimes. I understand that answering the same questions or providing the same information all the time can suck, but dang dude..... You are starting to remind me of the guy on Gold Rush Alaska that everyone hates because he is such an @$$hole. I do think you know what you are talking about most times, but I wish you would stop being such an a** and just help people since that is what your job on this board is all about. Otherwise, maybe take some time off ..... I think your attitude and responses are sometimes why more people dont come on here and post things, because they are afraid of what kind of remarks you are going to reply with.....

Share this post


Link to post
Share on other sites

Sorry if I offended anyone, I'm a bitcomet user just like you are and volunteer my time to help run this forum, and have for many years. The rest of the staff and I also work hard to duplicate bugs so we can report our findings to development, and I certainly don't want to insult any user, but I do want our staff volunteers treated with respect, I couldn't run the forum without them, so as long as members are kind to staff, I'm happy.

I'm big enough to apologize if I offended someone, but this is a community forum for users to ask for help from other users, it's not here to complain about the product, or about those offering help.

ps. it's probably time I cleaned up or deleted this topic, it's all been discussed and it's become an eyesore.

Share this post


Link to post
Share on other sites

*topic closed*

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...