Jump to content
Comet Forums
afterall

How to Set up Portforwarding & Static IP Reply thread.

Recommended Posts

i'm using bitcomets 0.68 with port forwarding 51122, setting up in router Aztech DSL 600ER, and in my router the NAT and firewall are enabled. I followed exactly ur guide and instruction to have static ip, set bitcomets listening port to 51122, and unchecked upnp.

The problem is when doing this port forwarding test "If you want to check whether your Port is open or not (in other words, checking if your portforward worked), head to: https://grc.com/x/ne.dll?bh0bkyd2" it tell me, that my port is STEALTH. I have Windows XP SP2, with exception for port 51122 inclusive. So, this should not be a problem...what should i check / do the enable my port forwarding ?

In addition, looking at my bitcomets, peer section, i notice my initiation have local, and my remote words seems missing...but i can see all remote ip i guess as in pic1.jpg. So, is my port forwarding successful

setup ?

post-13847-1162095758.jpg

Share this post


Link to post
Share on other sites

No, it's not. If it is successful, then in the "INITIATION" column, you should see at least one labelled "REMOTE" instead of "LOCAL".

This means that something is still blocking your listen port. Try connecting your computer directly to the modem, bypassing the router. You will need to temporarily reconfigure your network settings for this, and go back to using DHCP, to perform the test.

If your listen port tests as open now, then the problem is with the router, and you need to check your port forwarding settings again. If the listen port still tests as closed, then you have a software firewall blocking the port. You may have more than one firewall installed, and any one of them can completely block the port even if the other(s) have it open. You will have to find it and remove it or open it. Running more than one software firewall is not a good idea. Many security suites also install their own firewalls, without being too clear that they're doing that.

Share this post


Link to post
Share on other sites

Now finally found out my antivirus program is having firewall blocking the port 51122. Thanks for the help...my port forwarding now really works, and the speed is really much much faster than before...

Thank You...

Share this post


Link to post
Share on other sites

Hopefully someone can help me with this problem. I am in college and I am trying to setup my BitComet portforwarding. I don't know if it is possible because I don't have access to the router that they use here. It is a wireless router. Any help?

Share this post


Link to post
Share on other sites

If you can't configure the router, you're probably not going to be able to get it working. However, some routers do allow incoming traffic on certain ports. You can try using port 80, which is the web server default. This is strongly not recommended if you have any alternative, btw.

Share this post


Link to post
Share on other sites

to dark shroud ive been following yr instuctions to the letter for port forwarding done everything untill i get to the page with the codes of yr modem. my ntl modem does nt seem to be on the list so i cant follow the instructions to finish the port forwarding.u did say to find it on the net but what do i put in the google ip address for ntl? if so where do i put it thanks for yr help

Share this post


Link to post
Share on other sites

kopside, can you please tell us exactly what the make and model is of your modem.

Look on the bottom or the side for the make and the model name/number

Share this post


Link to post
Share on other sites

what if the status is stealth? is that the same thing as if the random port you chose is open? I am trying the 50000+ port number, all i get also is invalid or stealth. does that mean that i need to change my port number? I can download but i only get as much as 20kbps download combined :(

Share this post


Link to post
Share on other sites

It's a binary answer. The good answer is "open", the bad answer is anything else, including "stealth" or "hidden" or "timed out". Changing the port won't help; the other port will be blocked too. You need to find/figure out what's blocking them, then make an exception rule for your listen port.

Share this post


Link to post
Share on other sites

i completed the port forwarding setup and it works fine. But my problem now is, after 1-2 days, it will seem no port is forwarded because the INITIATION become all "LOCAL".

I have to login router again, and re-SAVE the port forwarding setting, then only it back to normal. Anyone had this problem? is this router problem?

I am using Linksys AM300 router modem. Please advice.

Thank you.

Share this post


Link to post
Share on other sites

i completed the port forwarding setup and it works fine. But my problem now is, after 1-2 days, it will seem no port is forwarded

Did you give your PC a static IP???

-if you dont then your PC might receive an IP that is different from the one you used in the portforwarding rule.

-if you give your PC a static IP then the portforwarding rule will always work.

Share this post


Link to post
Share on other sites

Did you give your PC a static IP???

-if you dont then your PC might receive an IP that is different from the one you used in the portforwarding rule.

-if you give your PC a static IP then the portforwarding rule will always work.

yes, i already did set my IP as static IP. As i said it happened after 1 day or so which i didnt switched off my PC at all. I let it run non-stoply.

the 1st few download are ok. after 1-2 days i completed the download, i start another download. Then this download shown "local" at INITIATION. No more Remote. What happened actually ? Router problem ? :(

Share this post


Link to post
Share on other sites

It's easy enough to check. Use IPCONFIG to make sure your IP is what you think it is, and double-check your router to see if the rule is pointing to the same IP. If not, you've probably made an error in setting the static IP, so check that again and set it properly. (This is a problem on the computer end, not the router, btw.)

(It's not necessary to reboot or shut the computer off, for DHCP to reassign an IP address. There's no apparent indication that it has happened at all.)

Share this post


Link to post
Share on other sites

Hi guys,

Got a bunch of questions, hope someone could help me out...

1. Um, this might sound stupid, but where exactly in this post is Soraiya's guide to how to portforward? I couldn't seem to find it, some guy quoted a lot of stuff in page 3 of this post and that's where i got my instructions...

2. I followed the instructions as per that quote, but when i went to test the custom probe thingy, the port (5xxxx) is still "stealth", not open (it passed the solicited and unsolicited packets, but not the ping reply test. Other random ports i tested passed all the tests including the ping reply test) Also, when i click on "peers" for any of my torrents in bitcomet, their all local, not a single remote one.

3. I am using a LinkSys WRT54GS, Windows XP SP2, with Avast Antivirus and ZoneAlarm Pro. Could the av and the firewall be interfering with it? If so, how do I change the settings on them such as to "forward the port"? Because i've tried meddling with the settings but i don't really know if the port is forwarded or not.

4. My brother is using a laptop (both of us are plugged into the router by cable, not using wireless). He uses bitcomet also, do i have to do this port forward and static ip thing for him? If so, would we be using the same ip or not, and would we be using the same listening port on bitcomet?

5. Just a question - doesn't opening that particular port mean that that port is vulnerable to attacks and spyware and stuff?

(edit) 6. I just read about this UPNP thing that apparently does away with port forwarding?

Thanks!

Share this post


Link to post
Share on other sites

Hi guys,

Got a bunch of questions, hope someone could help me out...

1. Um, this might sound stupid, but where exactly in this post is Soraiya's guide to how to portforward? I couldn't seem to find it, some guy quoted a lot of stuff in page 3 of this post and that's where i got my instructions...

That one's in the sticky, or "pinned" section above this one.

2. I followed the instructions as per that quote, but when i went to test the custom probe thingy, the port (5xxxx) is still "stealth", not open (it passed the solicited and unsolicited packets, but not the ping reply test. Other random ports i tested passed all the tests including the ping reply test) Also, when i click on "peers" for any of my torrents in bitcomet, their all local, not a single remote one.

Two sides of one coin, means your listen port is still being blocked by something.

3. I am using a LinkSys WRT54GS, Windows XP SP2, with Avast Antivirus and ZoneAlarm Pro. Could the av and the firewall be interfering with it? If so, how do I change the settings on them such as to "forward the port"? Because i've tried meddling with the settings but i don't really know if the port is forwarded or not.

The AV, probably not. The firewall, certainly. That's what firewalls do, after all. But there are many problems with ZA particularly, and it's not recommended. However, you will have to uninstall it, because simply disabling it doesn't. You will need to make a rule for whatever firewalls you do have, to open BitComet's listen port to TCP and UDP traffic.

4. My brother is using a laptop (both of us are plugged into the router by cable, not using wireless). He uses bitcomet also, do i have to do this port forward and static ip thing for him? If so, would we be using the same ip or not, and would we be using the same listening port on bitcomet?

Yes, you do. No, you can't use the same IP, no two devices on a network can have the same IP address. Because the combination of IP + Port is (must be) unique, it doesn't matter if you use the same port or not. But each IP will need a forwarding rule for the port, whether it's the same or different.

5. Just a question - doesn't opening that particular port mean that that port is vulnerable to attacks and spyware and stuff?

Yes it does. So don't open ports that you don't have an application listening on and want unsolicited traffic for. If something comes through BitComet's listen port, and BitComet doesn't understand it, it will simply ignore it.

(edit) 6. I just read about this UPNP thing that apparently does away with port forwarding?

If and only if it works on your router and your system. It usually doesn't, or ends up being more trouble than disabling UPnP on the router and doing it manually.

Share this post


Link to post
Share on other sites

hello

i'm italian so I apologize before for my engrish :blink:

when i try to check my ports it says that they are all STEALTH

I have a router (3com 3crwdr101a-75)

i follow all the step that i foud here (http://forums.bitcomet.com/index.php?showtopic=3880) and here (http://www.portforward.com/english/routers/port_forwarding/3com/3CRWDR101A-75/BitComet.htm)

i have a static ip (192.168.1.2)

my router ip is 192.168.1.1

my listening port is 50000

i have set the "virtual server" in the right way

I have only one doubt:

when you say "Once you've done that, click Ok, Ok, then close. Restart your internet connection." (before going to www.portforward.com) i don't know how to restart my internet connection because my router is a modem too and it's always connected (i don't have to do nothing when i switch it up). i tried to restart my router but it was useless

i have sp2 but my firewall is off because my router have a firewall too but i did what www.portforward.com says to allow the listening port

i have swiched off the Upnp mapping

i use bitcomet 0.76

please help me (using a "simple english :P )

Share this post


Link to post
Share on other sites

Hi Kluelos,

The AV, probably not. The firewall, certainly. That's what firewalls do, after all. But there are many problems with ZA particularly, and it's not recommended. However, you will have to uninstall it, because simply disabling it doesn't. You will need to make a rule for whatever firewalls you do have, to open BitComet's listen port to TCP and UDP traffic.

Is there any other solution than uninstalling ZA? Cos i really love ZA, never had any security problems since i started using it. Besides, under the "program control" section of ZA, i gave my bitcomet a "super" trust level, plus a whole row of green ticks for "access" and "server", i read in some other forums that this should be enough...?

Yes it does. So don't open ports that you don't have an application listening on and want unsolicited traffic for. If something comes through BitComet's listen port, and BitComet doesn't understand it, it will simply ignore it.

I don't quite get you, you mean if i get a spyware attack on that particular port nothing will happen?

Thanks.

Share this post


Link to post
Share on other sites

It's easy enough to check. Use IPCONFIG to make sure your IP is what you think it is, and double-check your router to see if the rule is pointing to the same IP. If not, you've probably made an error in setting the static IP, so check that again and set it properly. (This is a problem on the computer end, not the router, btw.)

(It's not necessary to reboot or shut the computer off, for DHCP to reassign an IP address. There's no apparent indication that it has happened at all.)

I obtained MCSE, its easy enough to have set a static IP.

Why i suspect the router problem is because, when i see no "Remote" at the Initiation, what i do is go to Port Forwarding page in Router, Re-save the settings. Then restart the download in Bitcomet, the "Remote" will shown. So without changing any setting at PC, just RESAVE settings for Port Forwarding, it'll run.

Its funny to do it this way everytime. Any known issues on Linksys AM300 ?

Current settings are :-

Static : 192.168.1.2

Subnet : as usual

Gateway : 192.168.1.1

Port forwarded to 49123.

Share this post


Link to post
Share on other sites

Wierd, so are your portforwarding rules getting deleted or are they still there but just not working?

So you say that you re-enter the portforwarding rule and it works. How long does this new rule work for?

The AM300 has upnp, you might want to use this (if it works) so you dont have re-enter the forwarding rules.

Share this post


Link to post
Share on other sites

Malware out on the internet will probe your computer's various ports, hoping to find one thats open and has a listening application it can subvert. There are some, like the system messenger application, that do this by default. It's intended to listen for messages from, e.g., system administration, to tell you that the network will be going down.

In order to "listen" an application has to register with your WinSock, telling it to send messages addressed to a particular port number. Most current implementations won't allow a second app to listen on any one port.

Firewalls trump the problem by closing all the ports, unless specifically told to open one.

So malware needs both an unblocked port, and a compliant listening application that it can subvert -- or a previously installed trojan application that's waiting to be contacted by its master.

If the Winsock gets a packet for a port that it has no registered listener for, it discards the packet and there's no problem. If the packet's port does have a listener app, it gets passed along to that app, which tries to evaluate the packet content. If that content is wrong (doesn't match what the app was expecting), it gets NAK'ed, instructing the sender to try again -- this is assuming that something corrupted the packet during its journey, and not that the packet was never correct in the first place. A legit sender would try again, but here the effect is to tell the malware that this port ain't going to work. The net effect though is that there's still no problem for the recipient. The app got what looks like a malformed packet (happens all the time), and says "I didn't understand, try again", which also happens all the time.

Share this post


Link to post
Share on other sites

Ok guys i see there is a lot of pages of FAQ and help posts. These days i have a lot of trouble about torrent downloading. I'm pretty new in these stuff and since i have first time opened any torrent client i have a problems with download speed. I use an ADSL connection (256/64) (Damn! i am from Serbia) and have Actiontec home dsl modem Model # UD800TP ,Windows XP sp1 without any firewalls and such things. Any torrent i choose to download , no matter if there are lot of peers/seeders my download speed is very variable. In one moment it is 2kb in other it is 16kb,5kb,22kb....In one word avarage is around 11-12kb/s. ipconfig shows me these values:

i.e.

connection-specific DNS suffix ........ empty

ip address..................194.106.190.26

subnet mask .............255.255.255.255

default gateway..........194.106.190.26

I have tried all-around torrent clients and i think that bitcommet is the best(interface,userfiendly...) but my problem is still there. I read carefully posts in this topic and tried all advices that i can understand. If anyone have an idea about what should i do i will be very greatfull!

Laza

P.S.

I have a dynamic ip

Share this post


Link to post
Share on other sites

Hi,

With your internet connection, your not going to get much better.

Your ISP measures you speed in "bits", and bit torrent protocall measures in Bytes.

Your max download speed of 256kb/s is equal to 32kB/s, and your upload speed of 32kb/s is equal to 4kB/s

So, the fastest speed possible is 32kB/s, but since bit torrent provides more download to those who upload the most, your speed will more closely resemble your max upload of 4kB/s

On very well seeded torrents, you may see speeds approaching 30kB/s, but not on a regular basis. The only relyable way to get better speeds would be to upgrade your service, however we can help you get the best with what you have.

First, to limit the amount of overhead, you should disable DHT (then restart bit comet).

NEVER run more then one torrent at a time.

Set your max upload to 3kB/s when downloading, and unlimited when seeding.

(please not that this advice should not replace fully going through our settings guides.)

Once you have your settings, download one of the following torrents...

http://distribution.openoffice.org/p2p/index.html

they are very well seeded, and will give you an idea of what your client can do.

Keep in mind that the biggest problem with slow torrents is peers that run multiple torrents without enough upload bandwidth to support them. For example, I provide between 50 to 80kB/s upload when I'm running a torrent, and only run one at a time. Since you can't upload more then 3 or 4kB/s, to run more then one would slow down anyone you connect to.

Suspect

Share this post


Link to post
Share on other sites

thanx a lot, i'm gonna try that DHT disabling right now....and yes i knew that 256=32kb/s...anyway THANK YOU!

I am downloading that torrent you have given...and speed is constantly 27kB/s so i presume that i usually select bad torrent files , but it is so hard to find good seeded torrent these days...

Share this post


Link to post
Share on other sites

what the italian people have done to you to make you boycot me at all

Anybody figured out what he's talking about?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...